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1 SAS Overview 

This document consists the technical specification and short manual of KES NetzAgent 

Substation Automation System.  

As default, SAS uses IEC 61850 SCL configuration files (Substation Configuration *.scd) or IED 

configuration file *.icd). For basic case, receiving analogs and signalization, charts, storing into 

database, no additional engineering is required. This dramatically reduce the amount of work 

to prove the communication and data. The setup file is the same as is used for protection 

itself. 

Start of the system is just open file operation and start the communication. The system is up 

and running in few minutes. 

HMI interface for single line diagram is based on Scalable Vector Graphics (SVG). This allows 

easy scaling of the pictures and all used symbols in the project are user defined. High flexibility 

and no proprietary format. 

All data are stored inside SQLite3 database (up to 140TB). The database is not encrypted, it 

could be open with any other tools or simple moved between different operation systems or 

computers. 

  



 

  

1.1 SAS features 

NetzAgent SAS has the following features: 

 Single user Master SCADA/SAS with integrated HMI interface 

 Single line diagram (SLD) with Scalable Vector Graphics (SVG) 

 SVG Editor Inkscape is used for SLD 

 Logging 

o Alarms 

o Events 

 Hierarchically relation of objects in database and presentation 

 Relation database SQLite3 

 Possibility to interchange database between Windows and Linux systems. File copy 

operation. 

 Database is NOT encrypted. User with appropriate right can use simple SQL command 

to browse DB. 

 No addition cost of third party software 

 User defined number of Masters 

 Supported protocols 

o IEC 61850 

o IEC 60870-5-104 (optional) 

o MODBUS (optional) 

 Number of I/O Point is limited with license contract 

 Plotting 

o Real-time plots of current values 

o Charts from historical database 

 Storing of data for analysis and export. Received measurements and signalization are 

stored into database with timestamps. 

 DB Export 

o Export into CSV file 

o DB can by simply copied and used 

 DB Backup 

 In house developing and testing 

 Platform independent and portable code, directly support 

o Linux 64 bits (Centos 7) 

o Microsoft Window 64 bits 

 Object oriented development based on C++11 

 1 year warranty period included 

 upgrade and maintenance for user defined period (optional) 

 



 

  

2 NetzAgent Short Manual 

This is the short manual related to Windows and Linux version of the SAS NetzAgent. 

The NetzAgent™ is single user SCADA / Substation Automation System (SAS), uses the latest 

technology, supports main communication protocols (including the new standard protocol IEC 

61850) and is independent from the operating system. It can work under Windows, Linux as 

well as other devices such as raspberry PI. This feature is of major importance for 

incorporating low cost solutions that are also compatible with the existing data. Another 

important feature is that the SCADA-System includes an interface to the real-time database, 

which enables the incorporation of further applications independent from the ones we offer. 

These features enable to reduce significantly the installation costs, especially when targeting 

a distributed model in the distribution network, for example by using Raspberry PI devices. 

Build-in Single line diagram (SLD) is the representation of a power system using the simple 

symbol for each component. The SLD of a power system is the network which shows the main 

connections and arrangement of the system components along with their data. SLD takes the 

current status of the topology elements and shows different symbols according the topology 

status. 



 

  

3 Installation 

The software installation comes as the archive in two types: 

NetzAgent_ZZZXXYY.tar.gz  Linux Centos 7 64 bits 

NetzAgent_ZZZXXYY.7z   Windows 64 bits 

 

3.1 Windows Installation 

 

3.1.1 Preinstallation Requirements 

The NetzAgent, requires installation of WinPcap driver. WinPcap is the industry-standard tool 

for link-layer network access in Windows environments: it allows applications to capture and 

transmit network packets bypassing the protocol stack, and has additional useful features, 

including kernel-level packet filtering, a network statistics engine and support for remote 

packet capture. 

Download WinPcap_4_1_3.zip from FTP site (ftp.kajganic.com). Unpack the archive to one 

destination folder. Start installation program WinPcap_4_1_3.exe and install Winpcap driver 

on your system. 

3.1.2 Installation 

Download NetzAgent from FTP site (ftp.kajganic.com). Unpack the archive to one destination 

folder. The archive is not password protected. 

3.2 Linux Installation 

 

Linux version of NetzAgent is tested on: 

[kes@KES]$ cat /etc/redhat-release 

CentOS Linux release 7.3.1611 (Core) 

And 

[kes@KES]$ cat /etc/redhat-release 

CentOS Linux release 7.2.1511 (Core) 

 

ftp://ftp.kajganic.com/
ftp://ftp.kajganic.com/


 

  

3.2.1 Preinstallation Requirements 

Usage of NetzAgent required one computer with Centos 7 64 bits operation system. Download 

the ISO disk (CentOS-7-x86_64-Everything-1611.iso) from Centos web site 

(https://www.centos.org/download/) 

a) Install Centos 7 64 bits version with default settings. 

Write down root password and create user for the usage of NetzAgent. Let’s call user kes 

in the rest of the documentation. 

b) Login in the system as root 

Open terminal and install the missing software. 

[root@KES]$ yum install gnome-packagekit-updater 

[root@KES]$ yum install gnome-packagekit-installer 

[root@KES]$ yum install dconf-editor 

[root@KES]$ yum install SDL 

[root@KES]$ yum install xerces-c 

c) VNC Server 

Strictly speaking VNC server is not require for proper work of NetzAgent, but it is used for 

remote access in the case of software update or maintenance. Install as root: 

[root@KES]$ yum groupinstall "GNOME Desktop" 

[root@KES]$ yum install tigervnc-server 

[root@KES]$ firewall-cmd --permanent --zone=public --add-service 

vnc-server 

[root@KES]$ firewall-cmd --permanent --add-port=5900-5999/tcp 

[root@KES]$ firewall-cmd --permanent --add-port=5800-5899/tcp 

[root@KES]$ firewall-cmd --reload 

d) Add sas folder 

[root@KES]$ cd / 

[root@KES$ mkdir sas 

[root@KES]$ chmod 777 sas 

e) Reboot the computer 

f) Login as user kes. This could be any user chosen during the installation process. 

g) Start VNC Server 

Open terminal. 



 

  

[kes@KES]$ vncserver -geometry 1280x960 :33 

First time, the program will ask for the password of the remote session. 

To stop vncserver use kill command. 

[kes@KES]$ vncserver -kill :33 

h) Test VNC connection from Windows to Linux computer 

Download on Windows computer TightVNC software from 

http://www.tightvnc.com/download.php. and start the installation. Use custom 

installation and install only VNC Viewer, Server side is not required. 

Start TightVNC Viewer  

 

 

Use IP address of the Centos computer with the same number used to start vncserver. 

 

http://www.tightvnc.com/download.php


 

  

For the password use the same password used to start vncserver first time. 

 

 

i) How to execute a script just by double clicking like .EXE files in Windows? 

Follow these steps: 

Hit Alt+F2, type dconf-editor and hit Enter. 

In dconfg-editor goto: org ➤ gnome ➤ nautilus ➤ preferences 

Click on executable-text-activation and from drop down menu select: 

launch: to launch scripts as programs. 

OR 

ask: to ask what to do via a dialog. This is preferable option in the test phase. 

Close dconf-editor. That’s it! 

 



 

  

3.2.2 Installation 

The installation of the software is under normal user (not root). 

Download Linux version (extension tar.gz) of NetzAgent from FTP site (ftp.kajganic.com). 

Unpack the archive to sas folder, created as root in previous step. The archive is not password 

protected. 

[kes@KES]$ tar -xzvf NetzAgent_ZZZXXYY.tar.gz 

 

New folder NetzAgent with appropriate structures and the programs is created. 

 

Copy as root user, the file 99-matrix.rules into /etc/udev/rules.d and test if the dongle is 

founded. 

 

[kes@KES]$ ./dongletest 

There is a MXSPS dongle connected to USB. 

Model:   651 

Version: 6.0 

Memory:  60 

 

 

 

ftp://ftp.kajganic.com/


 

  

4 Start of NetzAgent 

 

4.1 Windows version of NetzAgent 

 

The program could be started with double click on the NetzAgent.exe from Windows Explorer. 

 

 

4.1.1 Debug Output 

NetzAgent has integrated debug output window. To achieve debug output, the application 

must be started with /D as command parameter or simple execute debug.bat.  

In the debug output user can see internal states of the program as the complete 

communication between NetzAgent and IEDs. 

 



 

  

 

4.1.2 Open SCL configuration file 

User could use File ➤ Open or press Open icon. 

 

In Open dialog chose Substation Configuration (*.scd) or IED configuration file (*.icd) 

 



 

  

The Imported configuration file create workspace and the project inside the program as is 

showed in the next picture. 

 

 

4.1.3 Single Line Diagram 

If exists a single line diagram file (*.svg) with the same name as the IED configuration, the file 

will be opened automatically when user opens the IED configuration file. Otherwise open the 

file with selecting open operation (File ➤ Open). Demo predefined SLD (Demo.svg) are 

located inside Demo folder.  

Remarks: The measurements and the signalizations are connected inside Demo.svg. 

 

 



 

  

 

 

Click on the “Button” opens the new SLD picture. Click on the measurement opens real time 

plots and the click on the breaker or disconnector change the topology.  



 

  

 

4.1.4 Communication 

Start and Stop of the communication is toggle operation. 

 

Configuration data from SCL file is sent to IEC61850 Driver. The driver sent the received data 

back to the application. Some IEDs as GE F650 has only rudimentary support of IEC61850. The 

report are not working properly. If the driver detect error in the subscription of the report, 

the driver will emulate report with cyclic pooling of the data set. 

4.1.5 RT Chart 

Click on analog measurement will open real time chart for the current selected measurement. 

The chart is updated as the new data are received. 



 

  

 

 
 

Second option to open real time chart is from toolbar. Select the first IED in the tree control. 



 

  

 

Click on RT Chart in the toolbar. 

 

Chose one or more (all) analog measurements assigned to the IED. 

 



 

  

The same chart will be opened as is chosen from single line diagram. The dialog is receiving 

the data from connected IED. The communication must work otherwise the dialog is empty.  

4.1.6 DB Chart 

Every received measurement are stored in the relation database with appropriate timestamp. 

Click on DB Chart in the toolbar. 

 

 

Chose the analog measurement(s) and the interval. 

4.1.7 Export Chart 

All received data are stored in the relation database with appropriate timestamp. Click on 

Export Chart in the toolbar. 



 

  

 

Select time range, exported values and the name of the CSV file where the data will be stored. 

 

Example: Part of the exported data: 

entryID;timeOfEntry;reasonCode;dataRef;value 

1;2017-05-06 09:04:19;4;simpleIOGenericIO/GGIO1.SPCSO1.stVal;true 

2;2017-05-06 09:04:19;4;simpleIOGenericIO/GGIO1.SPCSO2.stVal;false 

3;2017-05-06 09:04:19;4;simpleIOGenericIO/GGIO1.SPCSO3.stVal;true 

4;2017-05-06 09:04:19;4;simpleIOGenericIO/GGIO1.SPCSO4.stVal;false 

5;2017-05-06 09:04:19;4;simpleIOGenericIO/GGIO1.SPCSO1.stVal;true 

6;2017-05-06 09:04:19;4;simpleIOGenericIO/GGIO1.SPCSO2.stVal;false 

7;2017-05-06 09:04:19;4;simpleIOGenericIO/GGIO1.SPCSO3.stVal;true 

8;2017-05-06 09:04:19;4;simpleIOGenericIO/GGIO1.SPCSO4.stVal;false 

9;2017-05-06 09:04:19;0;simpleIOGenericIO/GGIO1.SPCSO1.q;0000000000000 

9;2017-05-06 09:04:19;0;simpleIOGenericIO/GGIO1.SPCSO1.stVal;true 

9;2017-05-06 09:04:19;0;simpleIOGenericIO/GGIO1.SPCSO1.t;20170506055426.626Z 

10;2017-05-06 09:04:19;0;simpleIOGenericIO/GGIO1.SPCSO2.q;0000000000000 

10;2017-05-06 09:04:19;0;simpleIOGenericIO/GGIO1.SPCSO2.stVal;false 

10;2017-05-06 09:04:19;0;simpleIOGenericIO/GGIO1.SPCSO2.t;19700101000000.000Z 

11;2017-05-06 09:04:19;0;simpleIOGenericIO/GGIO1.SPCSO3.q;0000000000000 

11;2017-05-06 09:04:19;0;simpleIOGenericIO/GGIO1.SPCSO3.stVal;true 

11;2017-05-06 09:04:19;0;simpleIOGenericIO/GGIO1.SPCSO3.t;20170506055426.696Z 

 



 

  

CSV file could be open directly with Microsoft Excel for the additional analysis. 

 

4.1.8 Topology Change Commands 

If the communication is established, click on the breaker or disconnector will open the dialog 

to change the topology status of the selected element. 

 

 

Changed status: 



 

  

 

Remarks: This could work only if the SCL configuration file for the IED has commands and it is 

appropriate configured.  

4.1.9 Login 

Depends on the project configuration it is possible to set up the commands to be active only 

in the case if the user is login in the system. 

 

 

Default user and password are: sadmin/sadmin. 

4.1.10 Users administration 

By clikcking on the “Users” and “User List” menu shown on main screen, the dialog with user 

administration pops up. 

 



 

  

 

 

4.1.11 Alarm and Event List 

Alarms and Events are logged. The screen shows all alarms and events related to switchgear 

or protective relays that are important for substation operation. Alarms and Events appearing 

in the list ion strict chronological order. 

Filter operation allows: 

 Alarm and Events 

 Alarm Only 

 Event Only 

 

  



 

  

4.2 Linux version of NetzAgent 

The program could be started with double click on the NetzAgent.sh from File Explorer. 

 

Depend on chosen option in dconf-editor program will start or one addition dialog will 

popup. 

 

Run starts the program NetzAgent. 

Run in Terminal opens additional terminal and then start NetzAgent. This additional 

terminal shows the same debug output as is NetzAgent started with option /D in Windows 

version. This is useful for tracking the communication messages. 



 

  

 

 

The rest of the program usage is the same as for the Windows version. 

 



 

  

5 Editing Single Line Diagram 

 

The single line diagram is SVG file. Scalable Vector Graphics (SVG) is an XML-based vector 

image format for two-dimensional graphics with support for interactivity and animation. The 

SVG specification is an open standard developed by the World Wide Web Consortium (W3C) 

since 1999. 

Inkscape Editor (v 0.92) is used for the demo project. Download the last version from 

https://inkscape.org 

 

The SLD owns some symbols which could be reused. You can open the symbols pressing 

Shift+Ctrl+Y or from Menu Object ➤ Symbols 

https://inkscape.org/


 

  

 

Assign of the new values to the measurement is quite simple. Open XML Editor 

(Shift+Ctrl+X or from Menu Edit ➤ XML Editor) 

 

For Object id use the 61850 address and the link is reference to the symbol. In the example, 

the analog measurement from Transformer Bay 1 will be present as symbol AnalogMW. The 

symbol is predefined and all objects with the reference to the symbol, will look the same on 

the screen. In the symbol Analog MW %5.1 is use as output format of the value. If you are 

changing the id or symbol reference don’t forget to press Set otherwise the changes are 

ignored. 



 

  

The same logic is used for the circuit breaker. 

 

Example of the disconnector. 

 

The second way to assign IEC61850 address to the ID is with the help of Object properties 

(Shift+Ctrl+X or from Menu Object ➤ Object Properties)  

If you have changed the id, don’t forget to press Set otherwise the changes are ignored. One 

additional remark for Object properties. Inkscape do not like “/” as part of the ID. 

The IEC61850 address “Trans1F650F650/eveGGIO1.Ind20.stVal” will be stored as 

“Trans1F650F650_eveGGIO1.Ind20.stVal”. This is internally handled by NetzAgent and 

converted back to “Trans1F650F650/eveGGIO1.Ind20.stVal”. In any case you can use XML 

Editor to set id and avoid this difference between IEC61850 addresses and IDs. 



 

  

 

 

5.1 Symbols 

Using the references to the symbols open the possibility of unlimited use of different symbols. 

The symbols are not hard coded in the application, the symbols are completely in the user 

domain, and the user can change any symbols. Only required is to define class for the symbol 

Example: Class=”Analog”.  

This defines an analog measurement. The type of the analog measurement is defined with 

symbol id and it is used as reference from the object to the symbol. 

Example: 

<symbol 

       id="AnalogMVA" 

       class="Analog"> 

      <rect 

         id="AnalogMVA_background" 

         x="0" 

         y="0" 

         width="55" 

         height="21" 

         style="fill:#ffffff;stroke:#000000;stroke-width:0" /> 

      <text 

         style="font-style:normal;font-variant:normal;font-weight:normal;font-

stretch:normal;font-size:20px;line-height:125%;font-family:'Microsoft Sans Serif';-



 

  

inkscape-font-specification:'Microsoft Sans Serif';text-align:end;letter-

spacing:0px;word-spacing:0px;writing-mode:lr-tb;text-anchor:end;fill:#6a43e5;fill-

opacity:1;stroke:none" 

         x="50" 

         y="21" 

         id="AnalogMVA_value">%5.1f</text> 

      <text 

         style="font-style:normal;font-variant:normal;font-weight:normal;font-

stretch:normal;font-size:16px;line-height:125%;font-family:Arial;-inkscape-font-

specification:Arial;text-align:start;letter-spacing:0px;word-spacing:0px;writing-

mode:lr-tb;text-anchor:start;fill:#808080;fill-opacity:1;stroke:none" 

         x="57" 

         y="21" 

         id="AnalogMVA_unit">MVA</text> 

    </symbol> 

 

All symbols with the same class have “value” and “unit”. Value is format how will be number 

present to the user. In this case the format is %5.1f. The syntax is the same as printf in C or 

C++ language. Unit is just a text.  

Changing data associated with the symbol will affect all elements referencing to changed 

symbol in the svg file. The symbols are stored together with the file, there are no global 

symbols. 

 

5.2 Breaker and Disconnector 

Digital Measurements (single and double bits) are defined as N objects, with the same position 

(coordinates). Depend on a signalization only one of the status will be present to the user. 

Example: 

   <symbol 

   id="Breaker" 

       class="Switch"> 

      <rect 

         id="B_NU" 

         x="1" 

         y="1" 

         width="10" 

         height="10" 

         style="visibility:visible;fill:#ff00ff;stroke:#000000;stroke-width:2" /> 

      <rect 

         id="B_00" 

         x="1" 

         y="1" 

         width="10" 

         height="10" 

         style="visibility:hidden;fill:#ffff00;stroke:#000000;stroke-width:2" /> 

      <rect 



 

  

         id="B_on" 

         x="1" 

         y="1" 

         width="10" 

         height="10" 

         style="visibility:hidden;fill:#000000;stroke:#000000;stroke-width:2" /> 

      <rect 

         id="B_off" 

         x="1" 

         y="1" 

         width="10" 

         height="10" 

         style="visibility:hidden;fill:#ffffff;stroke:#000000;stroke-width:2" /> 

      <rect 

         id="11" 

         x="1" 

         y="1" 

         width="10" 

         height="10" 

         style="visibility:hidden;fill:#ff0000;stroke:#000000;stroke-width:2" /> 

    </symbol> 

 

For double bits status it is predefined: 

NU   Status is not updated, initial state of the switch 

00   intermediate status 

off (01)  Switch is open 

on (10)  Switch is closed 

11  bad status 

 

For single bit status it is predefined: 

NU   Status is not updated, initial state of the switch 

off  Switch is open  

on  Switch is closed 

 

5.3 Alarms 

Alarms are defined as N objects, with the same position (coordinates). Depend on a received 

signalization only one of the status will be present to the user. 

Example: 

    <symbol 

       class="Alarm" 

       id="Alarm"> 

      <rect 

         style="visibility:visible;fill:#ff00ff;stroke:#000000;stroke-width:2" 



 

  

         height="30" 

         width="30" 

         y="1" 

         x="1" 

         id="A_NU" /> 

      <rect 

         style="visibility:hidden;fill:#000000;stroke:#000000;stroke-width:2" 

         height="30" 

         width="30" 

         y="1" 

         x="1" 

         id="A_on"> 

        <animate 

           attributeType="XML" 

           attributeName="fill" 

           values="#800;#f00;#800;#800" 

           dur="1" 

           repeatCount="indefinite" /> 

      </rect> 

      <rect 

         style="visibility:hidden;fill:#ffffff;stroke:#000000;stroke-width:2" 

         height="30" 

         width="30" 

         y="1" 

         x="1" 

         id="A_off" /> 

    </symbol> 

 

Alarms has predefined statuses: 

NU   Alarm status is not updated, initial state of the alarm 

off  Alarm gone 

on  Object in alarm state (red blinking state) 
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